博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Heritage from father
阅读量:5970 次
发布时间:2019-06-19

本文共 1730 字,大约阅读时间需要 5 分钟。

http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1006&cid=22619

Problem Description

Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power. 
If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins. 
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.

Input

The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.

Output

对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

Sample Input

130

Sample Output

1.00E01.00E1

Hint

Hint
when N=1 ,There is 1 gold coins. 
when N=3 ,There is 1+3+6=10 gold coins.

Source

Gardon-DYGG Contest 1

#include<iostream>

#include <iomanip>
#include <cmath>
using namespace std;
int main()
{
    int a,b;
    double c,d;
    while(cin>>a)
    {
        if(a==0) break;
        d = a;
        c = log10(d/6)+log10(d+1)+log10(d+2);
        b = int(c);
        cout<<fixed<<setprecision(2)<<pow(10.0,c-b)<<'E'<<b<<endl;
    }
    return 0;

转载于:https://www.cnblogs.com/lengxia/p/4387884.html

你可能感兴趣的文章
mysql多实例实例化数据库
查看>>
javascript 操作DOM元素样式
查看>>
HBase 笔记3
查看>>
【Linux】Linux 在线安装yum
查看>>
Atom 编辑器系列视频课程
查看>>
[原][osgearth]osgearthviewer读取earth文件,代码解析(earth文件读取的一帧)
查看>>
使用dotenv管理环境变量
查看>>
Vuex学习
查看>>
bootstrap - navbar
查看>>
服务器迁移小记
查看>>
FastDFS存储服务器部署
查看>>
Android — 创建和修改 Fragment 的方法及相关注意事项
查看>>
swift基础之_swift调用OC/OC调用swift
查看>>
Devexpress 15.1.8 Breaking Changes
查看>>
ElasticSearch Client详解
查看>>
mybatis update返回值的意义
查看>>
expdp 详解及实例
查看>>
通过IP判断登录地址
查看>>
深入浅出JavaScript (五) 详解Document.write()方法
查看>>
Beta冲刺——day6
查看>>